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Your first day with the Newforma Model Viewer 
Congratulations! You are moving forward with your first project using the Newforma® Model Viewer, 
powered by VEO. This document will teach you everything you need to know to get started, using 
hands on, step-by-step approach. As a result, you'll immediately begin saving time and money and 
increasing productivity across the entire design, building, and operating team. 

Key learning outcomes: 

1. Export and navigate your first VEO project. 
2. Share your entire project with real-time collaboration. 
3. Think ahead to closeout, operations, and a BIM-to-FM deliverables. 

Introduction 

Getting your first project ready for collaboration in Model Viewer is very straightforward and easy. It 
only takes about an hour to create a useful Model Viewer project. Here are the basic steps to 
becoming immediately productive and sharing your project: 

• Exporting to Newforma Model Viewer 
• Cleaning up the project 
• Creating useful view settings 
• Using logic and archive 
• Sharing your project 

Once you share the project, other designers can remotely export their work to the same Model Viewer 
project. This is much faster than manually transmitting design files. As soon as new project information 
is available for anyone, it is available for everyone. This allows the entire team to communicate, 
coordinate and collaborate with confidence.  

Keep in mind as you start to create your first project that once your project is shared, everything you 
create will be available for other team members. It’s a good idea to plan ahead and organize your 
project with clear naming conventions. 

Creating login credentials to Newforma Model Viewer 

Create a user account at 
my.newforma.com. 

Now connect to companies you’re doing 
business with. Once you’ve selected the 
company and logged in, you’ll see a list of 
projects to which you have access. 

http://my.newforma.com/
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Now that you’ve logged into Info Exchange, you can log into Newforma Model Viewer:  

• User: Email address 
• Account: Company name 
• Password: Whatever you set up 

If Model Viewer is open, Revit will automatically detect your login. If Model Viewer is not open, you 
will need the above credentials before publishing your model to Newforma Model Viewer. 

First, the Newforma Global Admin will 
need to log into Newforma Model Viewer 
in order to assign people to projects. (This 
step will be automated in future releases, 
post-edition 10.1.) We recommend you 
create an External Team on the Manage 
account tab by selecting Add Group on the 
right side of the dialog under User Groups. 
Once the group is created: 

1. Select the user. 
2. Select the group you want to add 

them to. 
3. Press the highlighted arrow 

pointing to the right. (See image below.)  

To remove users, select them and press the highlighted arrow pointing to the left. 

Now that you have created user groups, 
you can add these groups to projects, 
making management easier.  

1. Select the group. 
2. Select the project. 
3. Expand and select either the Read 

or Write access group. 
4. Press the highlighted arrow 

pointing to the right.  

To remove them, select the group or 
individual under the project, and click the 
arrow pointing left. 

VEO login dialog 

Account Management dialog 

VEO Login Dialog 
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Account Management dialog 

 

Exporting from Revit to Model Viewer 

Install the plugin for Revit found by clicking this link or by selecting the link from within Info Exchange 
or Project Center. 

Open your Revit project in Revit 2013 or Revit 2014. You can export all the linked files together in VEO. 
In the future, imagine that you could distribute this effort, where each design team would only export 
their project (rather than wait for one person to export all the projects to VEO). As a result, it’s easy to 
see how the VEO project could actually be as up-to-date if not more up-to-date than the Revit files. 

 

 

All the links in this project are origin to origin. If this wasn’t the case you’d simply publish the 
coordinates from the Architectural file to each of the links. This will bring in all the links at the same 
location.  

The Revit project 

 

1 
2 

3 

http://help.newforma.com/Newforma_Project_Center_Tenth_Edition/desktop/Using_1/Install_the_AutoCAD_and_Revit_Exporters.htm
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If you ever export a Revit project containing links to VEO and the files are not in the same location, 
publishing the coordinates to each of the links and re-exporting will correctly locate the links. 

To start this process, you will need to first create and save a project in Newforma Model Viewer. Under 
the File menu, select New Project and enter your project name.  

For this exercise enter Amberbock and press OK.  

This new project will load; just save it by selecting Save under the File Load menu. You have now 
created a placeholder project in the Model Viewer to which you can export models, whether from 
Revit or AutoCAD. 

Select the VEO tab in the menu bar and then select Export All. 

 
VEO export menu 

After selecting the Export Now button your Revit Model will automatically map new model streams to 
VEO. Now you are one click away from publishing to the Model Viewer 

Each of the Revit files requires its own Model Stream in VEO.  
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Select Customize for additional options 

You have the option to control which model and parameters get exported to VEO 
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By default, VEO will export and 
group the following Revit 
Parameters: 

• Material 
• Family and Type 
• Level 
• System Type 

 

 

 

You can also export and tag 
additional parameters. Let’s 
export and tag the Rooms 
parameter from the 
Architectural file. The room 
names will be grouped as well.  

Begin by selecting the 
Parameters tab (between the 
Model Streams and Options 
tabs). 

1. From the Parameter 
Export Option pull-
down select Selected 
Parameters: 

2. Select Rooms. 
3. Check both Export and Tag boxes next to the Name & Number value. 
4. Now select Export. 

Exporting the VEO project with room names 

It will only take two or three minutes to export all six files. File size and the number of custom 
parameters selected during export impact the export time. When you export the same project in the 
future, you can select the Apply Previous Parameter Selections to automatically select previously 
selected parameters. 
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Load Project Dialog  

Open the project in VEO by selecting File > Load.  

 
Opening the VEO project 
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Add or Update Model Stream 

Now let’s load in the Model Streams:  

Under the File menu: 

1. Go to File > Project Structure. 
2. Select the Amberbock project under the Project Revision Name. 
3. Pick the Add Model Stream button to see the dialog below. 

 

 (Note that the ‘Show Models’ checkbox 
is only available for Admin accounts.) 

When finished, your project model 
should be visable in the main screen. 
Press OK. 
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Changing the settings 

 

 

Customize Mouse and Keyboard Controls 

Navigation in VEO is customizable, which we will cover below. 
As you navigate you’ll notice the file feels very light and 
responsive! 

• Rotate the view by pressing and holding the left mouse 
button.  

• Pan the view by pressing and holding the middle 
mouse button. 

• Zoom in / out by pressing and holding the right mouse 
button. 

• To quickly zoom and frame an object, hover over it 
with the pointer and double-click. 

• Select by holding down the ALT key while picking or 
using a selection window. 

• Hold ALT and Shift to pick multiple objects. 
• Temporarily Isolate a selection by toggling the Tab 

key. 

  

To change the navigation to 
mimic other applications, select 
the Settings icon (gear) located 
in the top right of the 
application. 
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Newforma Model Viewer now supports both feet and meters as units of measurements. You can select 
the unit of measurement from the General tab of the Settings dialog box, shown below: 

 

You can control the precision of the measurement information displayed. When Feet and Inches is 
selected, select the Use Fractional Inches (to Nearest 1/8th) to display measurements to an eighth of 
an inch. When Meters is selected, set the number of decimal places to display in the Decimal Places to 
Display Measurements field. 

Accessing Tool Panels 

From View menu, open the following menus as shown in the image at right:  
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Model Viewer Tool Panels 

Turn on the following Tool Panels 

     

Tags and Objects and Styling Tool Panels 

   

Master Presets and Sectioning Tool Panels 

 

Now is a good time to save your project! 
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Docking and Moving Tool Panels 

 

 

Configure your User Interface by dragging any menus not already docked to the sides of the screen as 
shown above. 

  

Drag Tool Panels to dock 
the side of your screen  

Stack multiple Tool Panels to 
reduce screen space 
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Searching and Controlling Element Visibility 

You can also search for elements by their Tag. Simply start to 
type in a few keywords and VEO will filter the appropriate tags. 
If you select the tag all the corresponding objects are selected 
and highlight in the model window.  

• Depress and release the Tab key it will isolate a 
selection. 

• Press F8 to Hide a Selection. 
• Press F7 to Show a Selection. 
• Press F9 to Show All. 

 

 

 

 

Visibility Options Via Right+Click  

 

You can also right-click in the model window to access the above options.  

When you export design projects to VEO you’ll see many objects that do not need to display. For 
example, geometry that is on a temporary Phase, Filled Regions, Detail Items and Analytic Planes. 
DON'T delete them. You may need them for reference and coordination purposes. 

The best practice is creating a Dynamic Tag for “Hidden Elements.” Now you can quickly select and 
Hide all the related Tags at once.  
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Let’s create a Dynamic Tag to hide unwanted elements 

Select Add (+) from the Tags and Objects panel. The next image illustrates the settings for the Dynamic 
Tag.  

• Create a filter search for analytic. Include all the Revit family types. 
• Expand the Material Name – CAD tag. Select Spaces and include. 
• Set the pull down menu from ALL to ANY. 
• Name the Tag Hidden Elements. 
• Select OK. 

Once you’ve created the Dynamic Tag, select OK. Then press F8 to hide all the analytic and space 
elements in your view. 

 
Creating a Dynamic Tag for Hidden Elements 
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Let’s now create a new Dynamic Tag to control all the elements that use 
glass as a material 
Dynamic Tags are also very useful for creating groups of common elements that you would like to be 
able to select en masse. At the moment, all the geometry is a solid gray color. Let’s create a Dynamic 
Tag select all glass materials in the project.  

Select Add (+) from the Tags and Objects panel. Expand the Material Name – CAD tag. Scroll down and 
use the shift key to select all the glass-related materials and include them in the tag definition as 
shown in the image below. 

Creating a Dynamic Tag for glass materials 
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Assign new Style to selected elements 

Once you select OK, all the objects with a glass material are selected. Let’s assign a new Style to the 
selection to make them transparent.  

• #1 Selects an element from the model 
• Select Styling tool panel 
• Select the Styles tab 
• Expand the Glass style. 
• #2 Select AGS Dielectric basic. 
• #3 Select Assign to Selected. 
• Select OK to accept the creation of a new Style Set. 

The steps are illustrated in the following image. All the glass materials are transparent.  

 
Assigning Glass Material to an Element 
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A new Style Set has also been created named Default_edit. Rename the Style Set to Default w/ Glass 
and select OK. 

 

 

Renaming the Style Set 

 

Now is a good time to save your project! 
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Creating Useful View Settings 

Master Presets can recall many view settings with one click. Rotated the view to show the front of the 
building. This will become your opening view. 

• Right click in the Master Preset window to create a Group named  VEO to organize your Master 
Presets. 

• Create a new Master Preset named 00 Opening View. 

 
Creating the Master Preset Group 

 

 
Settings for the 00 Opening View Master Preset 
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Selecting this Master Preset automatically recalls the view location and applies the present Style Set 
Default w/ Glass. 

Style Sets quickly apply numerous material styles with one click. VEO has five default Style Sets. Style 
Sets are useful for communicating real-world or analytic material settings. The default Style Sets are 
great starting points for creating custom Style Sets. Editing a Default Style Set will automatically create 
a custom Style Set. 

Let’s create a Style Set that displays analytic Materials to Objects based on their category. 

• Select the WireframeBlack-Thin Style Set. 
• Select various categories of elements based on the Tag_PhysicalType Tag such as 

StructuralFraming, Ducting, Piping and PlumbingFixture. 
• As you select each Tag, apply a different Style to the Tag. 
• Rename the Style Set “Physical Type.” 

 
Styles based on Physical Type 

Let’s create a Style Set that displays analytic Materials for Rooms volumes. 

• Select the Wireframe Style Set. 
• Select all the tags under the grouped tag Name category. 
• Apply the Style Grey Anisotropic Plastic. 
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• Right click in the view while the rooms are still selected and select Selection>Invert Selection. 
• Press F8 to hide all the building elements. 
• Select rooms by names and select a Style. 
• Select Assign to Selected to apply different Style to each of the room names. 
• Rename the Style Set “Room Name.” 
• Create a Master Preset called 01 Room Volumes with the following settings: 

 
Room Volumes Master Preset 
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Here’s an example of room volumes given different Styles: 

 
Room volumes with Styles applied 

Let’s create one more Master Preset to display the Physical Type Style set: 

• Select the 00 Opening View Master Preset. 
• Change the Style Set to Physical Type. 
• Save a new Master Preset named 02 Physical Type. 

 
Physical Type Master Preset 

Switching between the three Master Presets will immediately alter the materials, visibility, camera 
location and more! 

Tip! Experiment by creating different Style sets that display real-world materials. Be sure to begin by 
creating a new (or duplicating an existing Style Set). Be sure to make the desired Style Set active before 
editing the Style Set. 
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Now is a good time to save your project! 

Using Archive 

VEO Archive for can be used during Design, Construction and Operations. Any Document may be bi-
directionally linked to any Object or Tag. Assigning the Document to a Tag means every Object is 
associated to the document. Selecting the Document can show all Objects. Selecting the Tag or Object 
will show all Documents. 

Begin by opening the Document Viewer window via Archive>Document Library. Right-click in the 
Document Viewer window and select Create New Directory. Create three new directories:  

• 01 Design Images 
• 02 Construction Details  
• 03 Operation Manuals 

Drag and drop all the documents from the Archive Files folder to the document viewer window. 

• Add the office chair images to the Design Images folder. 
• Add the plumbing details to the Construction Folder. 
• Add Mastrena Cut Sheet.pdf to the Operations Folder. 

 

Assigning Documents to Tags creates a bi-directional relationship between the documents and the 
objects that the tags represent. Any new objects added to the project will automatically presume the 
relationship to the previously associated documents. 

Navigate to the lobby area and select the chair at the reception desk. Select any part of the chair and 
right-click to select the Revit Family Type associated to the chair.  

• Drag each of the office chair images to the tag associated to the chair. 
• Frame the chair in the view as shown with the Document viewer open. 
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Lobby office chair and associated options  

Finally, create another Master Present named 03 Lobby Chair Options with the options shown in the 
following image. When the Master Preset is selected, it will frame the chair in the view. Select the chair 
and display all the associated seating options images in Archive.  

This is a great way to visualize and communicate real-world design options without over-modeling in 
Revit. You can easily visualize all your options in context with the rest of the building! 
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03 Lobby Chair options Master Preset 

Next, search for and select any of the sinks in any of the washrooms. Assign the section details to the 
tag for the sinks in the washroom. 

Finally, search for and select the Mastrena Espresso Machine. Assign the manufactures cut sheet to 
the tag for the espresso machine. Tip: you can double-click a tag and it will frame the object(s). 

Now is a good time to save your project! 

 

Project Visibility 

Hiding your project cannot be undone. Once you hide your project, it is hidden forever! 

Once you share your project, only those who have been granted access can see it. 
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Project Updates 

Once you make changes in Revit you’ll have to re-export the project (along with any modified links). 
Once you’ve exported the project you’ll need to refresh the project in VEO. To update the VEO project: 

• The model window will have a pop-up message “You have Model Stream updates”  
• Click on Project Updates are Available link to open the Project Structure dialog. 
• Model Streams with updates are highlighted orange. 
• Select Update All. 
• VEO will refresh and show the latest information. 
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Model streams with updated project information  

 

Project Updates  

When a new revision is made to the project you are currently working in the project update 
notification icon activates by turning white.  

  

Select the Project Updates notification or File > Project Updates to open the Project Updates panel.  

Select Update Now to accept updates from other users 

 

 

“Project Updates are Available” 

For support, please join our M-SIX user forum at http://www.m-six.com/forum. 

 

Conclusion 

M-SIX VEO™ is a social platform that connects designers, builders and owners. And Newforma project 
information management software integrates the work of architecture, engineering, construction, and 
owner organizations. Together, they generate timely and accurate information that allows people to 
make informed decisions and avoid rework and revisions – wasting everyone’s time and money.  

When you are collaborating using the Newforma® Model Viewer, powered by VEO, project information 
that is available to anyone is available for everyone. By working together, the sum of everyone’s efforts 
becomes greater than the individual parts. 

We hope this lab allows you to be immediately productive. Please contact us if you have any 
comments, questions or suggestions.  

 

 

1750 Elm Street, 10th floor 

Manchester, NH  03104 USA 

+1 603.625.6212 

answers@newforma.com 

www.newforma.com 
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